Routing Information Protocol (RIP) adalah routing protocol yang sangat sederhana dan masuk dalam kategori Interior Gateway Protocol. RIP merupakan routing protocol dengan algoritma routing distance vector atau routing protocol yang hanya melihat arah dan jarak untuk menuju suatu jaringan tujuan. RIP tidak memiliki peta yang lengkap tentang jaringan yang ada. RIP menggunakan hop count sebagai metric dan link dengan hop count terkecil yang akan menjadi link terbaik (best path). Router-router yang menjalankan RIP akan saling bertukar informasi dengan router tetangganya (neighbor). Informasi yang akan dipertukarkan adalah tabel routing miliknya, dengan kata lain sebuah router akan mengirimkan atau meneruskan tabel routingnya kedalam neighbour router.

Berikut topologinya.



Gunakan kabel serial untuk masing-masing router
  
Konfigurasi router 1 :

Router(config)#int lo0
Router(config-if)#
%LINK-5-CHANGED: Interface Loopback0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
Router(config-if)#ip add 1.1.1.1 255.0.0.0Router(config-if)#ex
Router(config)#int se0/0/0
Router(config-if)#ip add 12.1.1.1 255.255.255.0
Router(config-if)#no shut
 
Konfigurasi router 2 :
Router(config)#int lo0
Router(config-if)#ip add 2.2.2.2 255.0.0.0
Router(config-if)#ex
Router(config)#int se0/0/0
Router(config-if)#ip add 12.1.1.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
Router(config-if)#ex
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
Router(config)#int se0/0/1
Router(config-if)#ip add 23.1.1.2 255.255.255.0
Router(config-if)#no shut

Konfigurasi router 3 :

Router(config-if)#ip add 3.3.3.3 255.0.0.0
Router(config-if)#ex
Router(config)#int se0/0/1
Router(config-if)#ip add 23.1.1.3 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up
Router(config-if)#ex
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
Router(config)#int se0/1/0
Router(config-if)#no shut interf
Router(config-if)#no shut interface se0/1/0
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
Router(config-if)#ip add 34.1.1.3 255.255.255.0
Router(config-if)#no shut

Konfigurasi router 4 :

Router(config-if)#ip add 4.4.4.4 255.0.0.0
Router(config-if)#ex
Router(config)#int se0/1/0
Router(config-if)#ip add 34.1.1.4 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

Setting RIP di router 1 :

Router(config-router)#version 2
Router(config-router)#network 1.0.0.0
Router(config-router)#network 12.0.0.0
Router(config-router)#no auto-summary
Router(config-router)#

Pada router 2 :
Router(config-router)#version 2
Router(config-router)#network 2.0.0.0
Router(config-router)#network 12.0.0.0
Router(config-router)#network 23.0.0.0
Router(config-router)#no auto-summary
Router(config-router)#


Router 3 :
Router(config-router)#version 2
Router(config-router)#network 3.0.0.0
Router(config-router)#network 23.0.0.0
Router(config-router)#network 34.0.0.0
Router(config-router)#no auto-summary

Router 4 :

Router(config-router)#version 2
Router(config-router)#network 4.0.0.0
Router(config-router)#network 34.0.0.0
Router(config-router)#no auto-summary
Router(config-router)#

Menampilkan table routing :

Router#sh ip route rip | B Gate
% Invalid input detected at '^' marker.
Router#sh ip route rip
R 2.0.0.0/8 [120/1] via 12.1.1.2, 00:00:16, Serial0/0/0
R 3.0.0.0/8 [120/2] via 12.1.1.2, 00:00:16, Serial0/0/0
R 4.0.0.0/8 [120/3] via 12.1.1.2, 00:00:16, Serial0/0/0
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R 23.0.0.0/8 is possibly down, routing via 12.1.1.2, 00:04:26, Serial0/0/0
R 23.1.1.0/24 [120/1] via 12.1.1.2, 00:00:16, Serial0/0/0
34.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R 34.0.0.0/8 [120/2] via 12.1.1.2, 00:00:16, Serial0/0/0
R 34.1.1.0/24 [120/2] via 12.1.1.2, 00:00:16, Serial0/0/0


R 1.0.0.0/8 [120/1] via 12.1.1.1, 00:00:16, Serial0/0/0
R 3.0.0.0/8 [120/1] via 23.1.1.3, 00:00:01, Serial0/0/1
R 4.0.0.0/8 [120/2] via 23.1.1.3, 00:00:01, Serial0/0/1
34.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R 34.0.0.0/8 is possibly down, routing via 23.1.1.3, 00:05:02, Serial0/0/1
R 34.1.1.0/24 [120/1] via 23.1.1.3, 00:00:01, Serial0/0/1
Router#


R 1.0.0.0/8 [120/2] via 23.1.1.2, 00:00:22, Serial0/0/1
R 2.0.0.0/8 [120/1] via 23.1.1.2, 00:00:22, Serial0/0/1
R 4.0.0.0/8 [120/1] via 34.1.1.4, 00:00:24, Serial0/1/0
12.0.0.0/24 is subnetted, 1 subnets
R 12.1.1.0 [120/1] via 23.1.1.2, 00:00:22, Serial0/0/1
Router#
R 1.0.0.0/8 [120/3] via 34.1.1.3, 00:00:20, Serial0/1/0
R 2.0.0.0/8 [120/2] via 34.1.1.3, 00:00:20, Serial0/1/0
R 3.0.0.0/8 [120/1] via 34.1.1.3, 00:00:20, Serial0/1/0
12.0.0.0/24 is subnetted, 1 subnets
R 12.1.1.0 [120/2] via 34.1.1.3, 00:00:20, Serial0/1/0
23.0.0.0/24 is subnetted, 1 subnets
R 23.1.1.0 [120/1] via 34.1.1.3, 00:00:20, Serial0/1/0


Silakan ping dari kiri ke kanan dan lanjutkan dari kanan ke kiri pastikan semua ok.

  
Router#ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/8/18 ms
Router#










Related Posts:

  • Cara membatasi bandwidth (limit) dengan mikrotikPengertian Bandwidth Bandwidth adalah luas atau lebar cakupan frekuensi yang digunakan oleh sinyal dalam medium transmisi. Dalam kerangka ini, Bandwidth dapat diartikan sebagai perbedaan antara komponen sinyal frekuensi tingg… Read More
  • Membuat Voucher Pada PHPMixxBill V4.5 A. Pengertian PHPMixxBill adalah sebuah paket aplikasi billing Hotspot dan PPPoE untuk mikrotik dengan menggunakan bahasa pemrogaman PHP dan menggunakan API mikrotik sebagai komunikasi dengan router. B. Latar Bel… Read More
  • Konfigurasi Static Routing dalam Interior Gateway ProtocolETHERCHANNEL merupakan penggabungan beberapa Link (Port Interface) menjadi satu group sehingga tanpa adanya port yang sia - sia seperti yang ada di Topology STP (Blocking Port), konsep dasarnya ETHERCHANNEL ialah menggabungka… Read More
  • Menghubungkan PC ke Internet Menggunakan Router MikroTik Bagaimana menghubungkan PC ke Internet menggunakan router MikroTik ? Alat yang dibutuhkan ada hardware dan software Hardware : a) PC/Laptop b) RouterBoard MikroTik c) Kabel UTP + RJ-45 dengan tipe kabel straight d) Jaring… Read More
  • RIPV2 Configuration Routing Information Protocol (RIP) adalah routing protocol yang sangat sederhana dan masuk dalam kategori Interior Gateway Protocol. RIP merupakan routing protocol dengan algoritma routing distance vector atau routing pro… Read More
Powered by Blogger.

Kategori

Total Pageviews

17869

Formulir Kontak



Popular Posts